Support
Authorization

Newsletter

  Settings

Mouse trail repaints the display

 

Forums list
Topics list
New topics
Search
Rules
Help
Login: 
Register

Pages: 1
  Views: 15036Topic:: «Mouse trail repaints the display» on forum: Famatech Beta Testing
#1
I have just installed the latest beta version of 3.0. When I remote into a dual-monitor PC, from a single monitor PC, the mouse trail "repaints" the local screen.

As the mouse traverses the screen it acts like an eraser and scrapes off the view of the topmost application in the view to reveal the desktop image of the remote PC.

I know this may be a confusing description but that's the only way I can put it. I've tried changing the behavior and style of the cursor on both machines but nothing helps.
Profile
#2
Hi Ron,

This is a common problem of Windows XP - http://support.microsoft.com/?kbid=899857

A mirror driver that is attached to the whole desktop cannot correctly draw the desktop background wallpaper in Windows XP

SYMPTOMS
In Microsoft Windows XP, a mirror driver that is attached to the whole desktop cannot correctly draw the desktop background wallpaper if the desktop covers more than one monitor

RESOLUTION
To resolve this issue, turn off the desktop background before you use an application that mirrors multiple monitors

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section

MORE INFORMATION
On the physical monitors, the desktop background wallpaper is drawn so that it is centered on each monitor. However, on the mirrored virtual desktop, the desktop background wallpaper is centered over the whole virtual desktop. Additionally, the wallpaper is the size of the first physical monitor. When the background painting occurs, the source of the drawing is the physical monitor instead of the mirrored virtual desktop. Therefore, background image corruption occurs

The following applications typically mirror the desktop:
• Screen capture
• Remote administration
• Help desk

Regards,
Profile
#3
I too have experienced this issue. Per the above MS document, I turned off the desktop wallpaper and tried it again. This did not fix the issue. It was less noticeable, because there was no wallpaper for the mouse to pick up and drag around, but any time I moved the mouse over an icon or over the start bar, a piece of the image there would be picked up by the mouse and smeared around with the subsequent mouse movements. On further testing, it was also doing the same thing with the blank background, but this wasn't apparent unless the background piece picked up by the mouse was smeared over something other than the background (blank background over blank background doesn't show up, obviously).

As Ron pointed out, this behavior is a little hard to describe. I'll see if I can get a screenshot tonight and post it. The salient point, however, is that there's more to this issue than the above MS bug. I might suggest you look into the code that draws the remote cursor.

smile:D
Profile
#4
I'm also experiencing mouse trails on my local monitor. The server is a 4 monitor (2 dual head Radeon X1300 vidoe cards) in a Windows XP media edition ( with all updates and patches ). I have my background set to NONE on the server and local computer. There appears to be something else going on here

I'm using Radim 3.0B2 installed on 8-30-06
Profile
#5
A co-worker resolved this on an ATI dual monitor setup by playing with the settings in the Catalyst Control Center. Sorry, can't tell you which setting.
Profile
#6
Quote
Microsoft wrote:
This is a common problem of Windows XP


But I have this problem with a Windows 2000...

My server is a Win2k and the client a Win XP. I have apply the suggested resolution on the server. But the problem is already present.

Does any one has a solution?
Profile
#7
Ok, I've got this figured out. It was NOT a change in the ATI settings that got this to work. You need to have a program like Ultramon to stretch your wallpaper to span all your monitors, then this should be resolved.
Profile
#8
SYMPTOMS
In Microsoft Windows XP, a mirror driver that is attached to the whole desktop cannot correctly draw the desktop background wallpaper if the desktop covers more than one monitor

RESOLUTION
To resolve this issue, turn off the desktop background before you use an application that mirrors multiple monitors

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section

MORE INFORMATION
On the physical monitors, the desktop background wallpaper is drawn so that it is centered on each monitor. However, on the mirrored virtual desktop, the desktop background wallpaper is centered over the whole virtual desktop. Additionally, the wallpaper is the size of the first physical monitor. When the background painting occurs, the source of the drawing is the physical monitor instead of the mirrored virtual desktop. Therefore, background image corruption occurs


So how do I turn off the wallpaper in win XP.
Profile
#9
Holy ancient thread bump, Batman!

First of all, if you read back through this thread, you'll see that turning off the wallpaper is not likely to help. However, if you want to try it, here's the procedure:

- Right-click anywhere on the desktop
- Select Properties
- Click the "Desktop" tab
- Set the Background to "None"

There are other recommendations I would make to you. First & foremost, make sure you are using the latest version of Radmin Viewer (v3.2 as of this writing). I believe they fixed this issue either in the release version of v3.0 or in v3.1.

The next thing I'd recommend, if you're still having the problem, is look into the UltraMon program. I use it now, and it's worth having if you use dual monitors, even if you fix the Radmin issue.

Hope this helps!
smile:)
Profile
#10
Hi

1. I have the desktop background set to none
2. I am using version 3.2 Radmin Viewer
3. I have been using Ultrmon for a long time now but maybe I don't have something set right
4. I recently changed video cards also but that didn't make any different either.

5. I am using Radmin server 3.0, maybe that is the problem. Hmmmm I believe that may be the problem. Do I just download a new version to the server and will it recognize my existing License? It would be absolutely wonderful if I can get this working like it shoule.

Thanks
Profile
#11
Oops! You're right, my mistake. It's the Server version that matters in this issue, more than the Viewer version. smile:oops:

You should be able to upgrade the server version with no ill effects on the license.

smile:)
Profile
#12
Ok

The server and viewer are both 3.2 now and I have rebooted but still have the streaks. Maybe I need to change something in Ultramon?
Profile
#13
I've tried various settings in UltraMon, and none of them have caused this issue to reappear.

I seem to remember that you may need to remove the RAdmin mirror driver from Device Manager, then re-run the Server 3.2 installer to reinstall the latest version of the mirror driver. Give that a try and see if that fixes it.

smile:)
Profile
#14
I removed the mirrow driver and then reinstalled and it didn't change anything.

If you like I can send you the info so that you can log into my computer and see it first hand which would probably save you some time.
Profile
#15
That might or might not help. I'm sure there are enough differences between my "viewer" computer and yours that if it works for me, we may not be able to figure out the difference. We can try it later, though, if we can't figure this out.

I've had another thought: I seem to remember that there was some issue with differences in resolution between the server and viewer. What resolutions are the displays on the two monitors on your server and however many on your viewer? Maybe we can tinker with those settings.

Also, if anyone from Famatech's support team sees this and would like to chime in, feel free.

smile:)

EDIT:

I've just remembered something else, and found a supporting thread here: http://www.radmin.com/support/forum/read.php?FID=24&TID=11226

Your primary monitor has to be left-most (and/or topmost, depending on your arrangement), so that the relative coordinates for the secondary monitor are all positive. I'd bet that right now your secondary monitor is left of (or above) your primary monitor. Swap which one is primary, and your problem will go away.

smile:D
Edited: TekServer 09/10/2008 11:22:31
Profile
#16
Resolutions are as follows on the server
1. 1024 x 768
2. 800 x 600
3. 1024 c 768

The resolution of the viewer is 1024 x 768

All set to 32 bit
Profile
#17
(See the edit I added on my previous post, if you haven't already.)

smile:)
Profile
Pages: 1

Users browsing this topic
Number of guests: 1, registered members: 0, in total hidden: 0

Radmin 3.5

Windows 8 Compatible

DOWNLOAD

Free for 30 days

BUY NOW

Only $49 per lifetime license
for  50 PCs - $29.8 per remote PC
for 100 PCs - $24.9 per remote PC
for 150 PCs - $23.3 per remote PC
from 200 PCs - $22 per remote PC
Follow us on Twitter
Famatech Corporation Copyright © 1999-2014 Famatech. All rights reserved.