Support
Authorization

Newsletter

  Settings

Radmin server v3.0

 

Search  Rules 
Close
Login::
Password::
Forgot your password?
Register
Login
 
Pages: 1
[ Closed ] Radmin server v3.0, requires Radmin server v3.0
 
I just downloaded the Radmin Viewer v3.0, & i am geeting this message "This connection mode requires Radmin server v3.0 or higher",
is there any way we can upgrade our softwear ?
 
Nope. Server 3.X is not available for public use at this time.
Pages: 1
Users browsing this topic (1 guests)

Radmin 3.5

Windows 8 Compatible

DOWNLOAD

Free for 30 days

BUY NOW

Only $49 per lifetime license
for  50 PCs - $29.8 per remote PC
for 100 PCs - $24.9 per remote PC
for 150 PCs - $23.3 per remote PC
from 200 PCs - $22 per remote PC
Follow us on Twitter
Famatech Corporation Copyright © 1999-2015 Famatech. All rights reserved.