Can't connect to server running under Win 2003


Search  Rules 
Forgot your password?
Pages: 1
Can't connect to server running under Win 2003
When i installed the Radmin 3.0 Beta 2 server on a Windows Server 2003 machine, I cannot connect to the server using Full control or View Only. I can connect using File Transfer.
When I try to connect to this machine, I get the login prompt, it accepts my username/password, shows the splash screen for a brief instant and then nothing happens. This does not happen on the XP machines I have tried it on.
Has anyone seen this and/or know how to fix it?
BTW, this works fine in RAdmin 2.x

Here is some of the log file:
<3420> RServer3 2006.07.15 19:46 Radmin Server v3.0 is started
<3576> RServer3 2006.07.15 19:48 Connection from JEFF ( (jeffc): Remote Screen connection
<3576> RServer3 2006.07.15 19:48 JEFF ( connection closed
<3920> RServer3 2006.07.15 19:55 Connection from JEFF ( (jeffc): Remote Screen connection
<3920> RServer3 2006.07.15 19:55 JEFF ( connection closed
<3972> RServer3 2006.07.15 20:00 Connection from JEFF ( (jeffc): File connection
<3972> RServer3 2006.07.15 20:01 JEFF ( connection closed
I am having the same issue too. I can't connect either. I am running Win2k3 server. Installation it self fails while installing the mirror driver. I cant' find the installation log. Error message I am getting is Installation of Radmin Server Components failed.
I have installed Radmin 3.0 Beta 2 server on Windows Server 2003 and have no problems using full control.
I've installed on 2 Server 2003/SP1 servers (upgraded from Server 2000) with no issues.
I have seen this on 2003 Servers with Version 2. We tracked it down to someone using Remote Desktop in Console mode. That seems to kill the ability to do a RAdmin connection after that point.

Haven't found a workaround yet - except to get those users to use RAdmin instead and prevent the problem :!:
Still no reply from Famatech.

In case you're wondering, I consider this to be a BUG, since 2.x works but 3.0 does not.

If this cannot be resolved, I will have to stick with 2.x connections to this server, whcih I would really rather not deal with since the new version should work.

Any response from Famatech?
We have had this issue with V2 as well as V3. When someone connects with MSTSC with the /console option, it screws up the Radmin server.

You can't connect as long as they maintain the console connection, but file transfer works.

Once they disconnect, you have to restart the Radmin server to be able to connect in.
I wish this was something that I could nail down to something like that. In this case there is nobody else connecting to the server (using Remote Desktop or MSTSC or anything else for that matter) as it is only a simple file/web/sharepoint server.

Also, this ONLY happens with 3.x server. I can connect to the 2.x server, poke around, disconnect, and then try to connect to the 3.x server (they are both installed on different ports) and I get nothing on the 3.x connection. I can then go and connect to the 2.x server again with no problem.

I'm not sure what could be strange about this machine as it has almost nothing installed aside from the base OS (SharePoint, DiskKeeper Pro, EZ Armor, Radmin 2.x and 3.x).

I can also do a complete reboot on this server and then restart 3.x server with no impromvement in the problem.

I would MUCH rather use the 3.x server since the 2.x server CRUSHES the CPU every time I connect.
I am pretty sure you aren't supposed to have both installed on the same server. In the same way that you can't have WTS owning the console at the same time as RAdmin, you can't have RAdmin 2 & 3 installed simultaneously. I would un-install both delete any directories, etc. and install ONLY 3.
I am pretty sure you aren't supposed to have both installed on the same server. In the same way that you can't have WTS owning the console at the same time as RAdmin, you can't have RAdmin 2 & 3 installed simultaneously.

This is not th case. I have Ramdin 2.2 and Radmin 3.0 beta 2 server install on serveral boxes one of them being Win 2003 server and can connect from both viewers no problem.
Stacey Cline
If you want to be able to get back into your box after an rdp session with radmin here's what to do: Remotely crash all process named csrss.exe, there will be one for your login session from radmin, and one from the rdp session. FYI there parent process is called smss.exe. How I figured this out: I used a program called Remote Task Manager to monitor what processes my rdp session was useing "csrss.exe" would run when i connected to the box. Then I noticed the same process was running with a different PID this was from my old radmin session. I don't have much time to test what one to kill, im on my way out the door from work but im sure you only need to kill one of them maybe check the processor time to determin the one to kill. If anyone gets a chance to explorer this more please post an update.

BTW: once you kill them it could take a few seconds for the process associated to restart, so give it a second and bingo your back in with radmin.
Well I figured that would be a bad idea and it was: Killing csrss.exe caused the server to crash and reboot.

I already determined that rebooting does not help, so this was not helpful.

Since this is a server and I actually need it to be up and running, I don't think I will bother trying to kill smss.exe.
Sorry it didn't work for you we have the same issues. If some one came in after us and used rdp we then lost the ability to control or monitor that box. We still had the function of file transfer, and the power button features. I've tryed the method I described on 2003 and xp, with out hick-ups. I'm suprised famatech hasen't commented on this thread??????? I'm sure there is a more efficient way to solve our problem, and I think a tool could be created.
I still have not heard a response from Famatech.

What are you guys waiting for???

I can provide you with any logs or settings you want. Just let me know.
Dear Jeffrey,

We investigate this problem, which is likely to be connected with the "Switch user" feature. This feature will be fully supported in the final release of Radmin v3.0. So far we would recommend not to use Remote Desktop in Console mode along with Radmin.

Thank you for using Radmin.
Thank you for the reply, but Remote Desktop is not even turned on on this machine or the client PC. Also fast-user switching has never been used on either machine.

However, the problem appears to have magically gone away today. I am unsure if it has something to do with the nes beta license key that I had to install tonight in order to test it, or if maybe some Critical Update for Windows was installed since the last unsuccessful attempt, but at any rate, it is working! I no longer have to deal with Radmin 2.x sucking up 80% CPU! This is a vast improvement.

So now that this is working for me, I will drop the subject. I don't really care what was wrong, as long as it works today.

This issue has just surfaced today at our location. When we uninstall RAdmin 3.0 and attempt to reinstall, we receive this message "Installation of radmin server components is failed". Consequently, when attempting to connect to this machine from another via RAdmin, we receive nothing but a small black square in the middle of the window.

Please advise.
Pages: 1
Users browsing this topic (1 guests)

Radmin 3.5

Windows 10 Compatible


Free for 30 days


Only $49 per lifetime license
for  50 PCs - $29.8 per remote PC
for 100 PCs - $24.9 per remote PC
for 150 PCs - $23.3 per remote PC
from 200 PCs - $22 per remote PC
Follow us on Twitter
Famatech Corporation Copyright © 1999-2018 Famatech. All rights reserved.